Roots Discourse

Installing Gutenberg via composer


#1

I’m trying to install gutenberg with composer but it doesn’t seem to be working.

The commands I’ve tried are:

composer require wpackagist-plugin/gutenberg
composer require "wpackagist-plugin/gutenberg":"4.4.0"
composer require "wpackagist-plugin/gutenberg:4.4.0"

The error I get is:

[InvalidArgumentException]
  Could not find a matching version of package wpackagist-plugin/gutenberg. Check the package spelling, your version constraint and that the package is availa
  ble in a stability which matches your minimum-stability (stable).

Is Gutenberg still unstable or am I doing something really daft here?!


#2

Have you tried to put the line directly in the composer.json file?

“wpackagist-plugin/gutenberg”: “4.4.0”,

Then composer update


#3

I think I did, I’ll double check though. After testing the plugin out by copying the files manually I wasn’t greatly impressed though, i get the feeling itll be a while till its stable and bug free, in spite of being due to go into core later this month!