Issue compiling

I’m receiving the following error when I run yarn build

$ bud build

 bud.hooks.event.get error: booted

There was an error while running a hook for the "booted" event.
The error occurred in hook #0.
The error message was:
Cannot read properties of undefined (reading 'instance')

I have tried the following with no success:
yarn dev
npm cache clean --force
yarn cache clean
and adding bud to my yarn.lock with yarn add @roots/bud --dev

Has anyone experienced this issue before?

Edit: Running WSL2 on Windows 11

This topic was tagged with Sage — are you using Sage? What version?

Is this on a fresh install? If not, are you able to re-produce on a fresh install?

Ben, thanks for the reply. Yes, this is for Sage, version 6.4.5. This is not a fresh install. I am able to successfully get this to build on a fresh install.

Edit: Fixed. This error ultimately appears to be a yarn dependency (yoga-layout-prebuilt) issue on WSL2 Ubuntu 20 on a symlink directory. Moved project “natively” fixed the issue.

I was having a similar issue when trying to repurpose an existing theme.

I solved it by explicitly reinstalling all the dependencies inside package.json

I am getting the same problem on Ubuntu