Roots Discourse

Issue with custom fonts import and Sage 9.0.10

Hello there !

I found a weird issue with the latest version of Sage 9.0.10 : when you’re importing custom fonts from the /fonts/ folder, I always have a Failed to compile with 1 error : This relative module was not found on my console when I run a yarn start

I’m used to work with Sage, and I tried with an project running with Sage 9.0.9, and everything works fine.

Steps to reproduce

  • Start a sage 9.0.10 project, add a font into your /fonts/ folder
  • Include your font with something like
@font-face {
  font-family: "Calibri";
  font-style: italic;
  font-weight: 700;
  src: url("../fonts/Calibri-Bold-Italic.ttf") format("ttf");
}
  • run a yarn start, you will see the error

I’m using node v12.20.1, latest WP version and php 7.4…

I don’t have any clue. For now, I’ll rollback to Sage 9.0.9 because it works with this version of sage.

Am I missing something ?

Thanks for the help

Are you already using this update branch for Sage 9.x?

No, I’m using the latest release here : https://github.com/roots/sage/releases so it’s the 9.0.10

You may find the update branch interesting as it should fix these kinds of build and watch/sync issues.