Issue with Sage SASS version

Everything ran smoothly through installation. Completed the instructions for using Sass.
After running gulp no compiling errors appeared but the main.css is returning:

/*# */

Any suggestions are appreciated.

That’s pointing to the source maps, so when you use something like Chrome Inspector to look at CSS, it doesn’t point to the minified CSS file, it points your styles to the actual LESS/SASS file the style was originally in.

Is this causing an error or something?

Well, its just that there’s no styling… at all.

You followed the instructions in ?

Yeap! Step by step. Already tried it in 2 different installations.

Versions I’m running with:

XXXXX-MacBook:~ XXXXX$ node --version
XXXXX-MacBook:~ XXXXX$ nvm --version
XXXXX-MacBook:~ XXXXX$ npm --version
XXXXX-MacBook:~ XXXXX$ gulp --version
[20:46:27] CLI version 3.8.11
[20:46:27] Local version 3.8.11
XXXXX-MacBook:~ XXXXX$ bower --version

I just did the same thing.

Checking the main.scss file, for some reason the @import was removed. Adding it back in and pointing it to Bootstrap includes all the styles.

checking this out right now

So, every time after running gulp the line:

@import "../../bower_components/bootstrap-sass-official/assets/stylesheets/_bootstrap.scss";

… disappears from within main.scss. In my case, even after putting it back no styling is being added.

Hmm I am not seeing this in isolation.

  1. What platform are you on?
  2. What version of node are you on?
  3. What does npm list --depth=0 spit out?
  4. Have you made any changes to bower.json?

edit: haha sorry saw that you posted this above

1 - Mac OS X 10.10.2
2 - XXX-MacBook:~ XXX$ node --version v0.12.0
3 -

XXX-MacBook:promptDev XXX$ npm list --depth=0
sage@8.0.0 /Applications/MAMP/htdocs/roots/wp-content/themes/promptDev
β”œβ”€β”€ asset-builder@0.4.1
β”œβ”€β”€ browser-sync@2.2.1
β”œβ”€β”€ del@1.1.1
β”œβ”€β”€ gulp@3.8.11
β”œβ”€β”€ gulp-changed@1.1.1
β”œβ”€β”€ gulp-concat@2.5.2
β”œβ”€β”€ gulp-flatten@0.0.4
β”œβ”€β”€ gulp-if@1.2.5
β”œβ”€β”€ gulp-imagemin@2.2.1
β”œβ”€β”€ gulp-jshint@1.9.2
β”œβ”€β”€ gulp-less@3.0.1
β”œβ”€β”€ gulp-load-plugins@0.8.0
β”œβ”€β”€ gulp-pleeease@1.2.0
β”œβ”€β”€ gulp-plumber@0.6.6
β”œβ”€β”€ gulp-rename@1.2.0
β”œβ”€β”€ gulp-rev@3.0.1
β”œβ”€β”€ gulp-sass@1.3.3
β”œβ”€β”€ gulp-sourcemaps@1.3.0
β”œβ”€β”€ gulp-uglify@1.1.0
β”œβ”€β”€ imagemin-pngcrush@4.0.0
β”œβ”€β”€ jshint-stylish@1.0.1
β”œβ”€β”€ lazypipe@0.2.2
β”œβ”€β”€ merge-stream@0.1.7
β”œβ”€β”€ traverse@0.6.6
β”œβ”€β”€ wiredep@2.2.2
└── yargs@3.3.1

4 - No changes to bower.json

PD. Is all cool! :stuck_out_tongue:


// bower:sass  


// bower:scss  
1 Like

Thanks for figuring that out, boss :blush:

You guys rock! Amazing team.

… silly mistake. It can happen to everyone.


Been testing the 8.0.0 branch with actual production Sass files for months! Barely tested the example file :stuck_out_tongue_winking_eye:

Where do you change that in main.scss ?

Is difficult to use Sage with Sass !
I did that and it works now but I need to comment the LESS files, It’s ok but is more work :frowning:
I would like to have those files!

mv layout/*.less layout/*.sass

For all files…

// Automatically injected Bower 
// bower:scss
@import "../../bower_components/bootstrap-sass-official/assets/stylesheets/_bootstrap.scss";
// endbower

//@import "common/_variables";
//@import "common/_global";
//@import "components/_buttons";
//@import "components/_comments"
//@import "components/_forms";
//@import "components/_grid";
//@import "components/_wp-classe
//@import "layouts/_header";
//@import "layouts/_sidebar";
//@import "layouts/_footer";
//@import "layouts/_pages";
//@import "layouts/_posts";


That’s just how it is right now.


This topic was automatically closed after 60 minutes. New replies are no longer allowed.