Roots Discourse

Issue with VM becoming unreponsive

Having some issues with an older project that’s been running just fine before I had my computer formated (at least a couple of months ago…).

I pulled down the project from git and ran vagrant up and started working on an update. Took a brea and when I came back a bit later I got ERR_CONNECTION_REFUSED in my face when refreshing.

Could not sort it out so I destroyed the VM and set it up again, worked a bit on the update and went home. Now a couple of hours later, it’s unresponsive again.

Not sure what could cause this. I just updated Vagrant and virtualBox to latest version. No dice.
I can SSH into the VM via vagrant ssh just fine. Restarted php-7.0fpm and nginx. No dice.
Tried doing this. No dice.

Out of ideas, and not very tempted to destroy and up to get in again. Any ideas?

System OS is macOS 10.13.6.

Edit: Only change I’ve done is to change TLD from .dev to .test as .dev doesn’t work anymore.

Not sure why, but, by mistake I changed the /etc/hosts file inside the VM. I commented out the first two lines as they looked weird to me. That caused my nginx start command not to run, so I removed it again.

And now it works again, weird.

This topic was automatically closed after 42 days. New replies are no longer allowed.