Roots Discourse

Issues with Vagrant Up on Trellis

I’ve gotten trellis completely set up on my machine and i’ve started having the rest of the dev team pull down the code and start testing it out on their own machines. A few people have gotten stuck on the vagrant up command and it’s not an error that I’m familiar with. Here’s a screenshot of the output when it breaks.

Does anyone have any idea what the issue might be? i’ve checked to make sure they have the correct installations of Vagrant, VirtualBox, ansible, and composer.

Well, when you visit that URL that results in a HTML response (soft 404) (instead the expected, parsable JSON), the repository/resource apparently doesn’t exist: https://galaxy.ansible.com/v1/roles/?owner__username=geerlingguy&name=composer
So the ansible galaxy tool tries to ensure that composer role exists, but it cannot find that role in the ansible galaxy repository under that user (geerlingguy) and role (composer).
Ansible Galaxy role page for that composer role from user geerlingguy: https://galaxy.ansible.com/geerlingguy/composer

There is an old, closed issue that matches the issue quite well: https://github.com/ansible/ansible/issues/63596
It has been fixed with later releases.
IMHO the ansible galaxy CLI tool is not compatible (anymore) with the current Ansible Galaxy.
It is probably an outdated ansible or ansible galaxy release and should be updated.

Side note: Slightly modifying that URL in the error message results in a correct API call + response btw:
https://galaxy.ansible.com/v1/roles/?owner__username=geerlingguy&name=composer (bad)
https://galaxy.ansible.com/api/v1/roles/?owner__username=geerlingguy&name=composer (good)
Just the /api part is missing in the URL.

1 Like

Thanks for the response! That does make a lot more sense and I do see that the URL in the attempted API call results in a 404. From the linked forum it looks like this is the pull request that solved this issue https://github.com/ansible/ansible/pull/63472. One of the team members is on ansible version 2.10.0.dev0. So maybe they need to downgrade their version? I’m runnning 2.9.11.

When they have to downgrade in order to fix this issue, it would mean that this issue had been re-introduced (regression). It can help to go the ansible versions up and down until a working/failing one is found. This helps figuring out whether this has been finally fixed or reintroduced.

1 Like

Yup that fixed it. Ansible version 2.10.0.dev0 seems to have reintroduced that API error. Thanks for the help!

This topic was automatically closed after 42 days. New replies are no longer allowed.