Roots Discourse

Latest Roots Sage 10 update with Bud not working with ACF Composer

I’ve installed and activated the latest roots sage theme and ACF Pro version 5.9 and can’t seem to get ACF composer working. No error messages, just no admin screens loading such as options.
Here is my current repo:

Any help would be amazing, apologies for using bitbucket, my Github is messing up.

Your app/Blocks/Hero.php is empty. Please delete the file, and run wp acorn acf:block Hero. Also make sure ACF Pro is active.

1 Like

Thanks for the reply and having a look!

I was just experimenting with the Hero.php to get some sort of error.

If I remove that to just test the options and have ACF Pro activated it still doesn’t work.

I’m just going to use a previous iteration of Sage for now as my project due quite soon.

Thanks again!

I just cloned your theme, and it seems you have an error in app/Options/Options.php:113. You’re calling endGroup() without addGroup().

Change

$options
            ->addTab('header')
            ->addText('heading')
            ->endGroup();

to

$options
            ->addGroup('groupname')
            ->addTab('header')
            ->addText('heading')
            ->endGroup();

I’m such a doughnut and I really thought that was it but still no luck.

The only major difference I see is the acorn composer package to beta from alpha, I’ve tried switching back to alpha but it throws a load of errors. I’m guessing it’s a compatibility issue there somewhere.

Thanks again on this, you’ve made me a more attentive developer at least :slight_smile: