Limited information for errors on build

Hey guys,

I just upgraded to Bud 6.6.10 and Sage 10.4.0 and have been running into a series of errors, mostly originating in my stylesheets. I assume this is caused by updates to Bud’s linter, and I don’t mind resolving them, but the error messages don’t give a location of origin in some cases, so they can be difficult to trace. I’m not sure if this is expected behavior, or if there’s something amiss with my configuration (which I would be happy to share, if needed). The screenshot shows a particularly vague one I’ve run into. Sure, I could track it down, but that would be time better spent elsewhere.

  1. Is this a bug?
  2. Is there a way to force verbosity here, or is there a configuration solution, perhaps?

Thanks in advance!

Screen Shot 2023-01-10 at 12.48.07

Are you running this in a VSCode terminal? I had an issue where the colors where off and the location information weren’t visible. I ran it in the Windows terminal instead and there the text was visible. Maybe this happens also in your issue?

No dice when I run it in Terminal on Monterey. What’s weird is that some errors output location info, while others don’t. Unexpected whitespace at end of line and some others, for example, gave me file and line as expected.

Edit: In case anyone else has the particular error I cited, I figured out that it was complaining about using double slashes to begin comments (e.g. // Menu styles). What’s also weird is that double slashes produced a different error in some cases (something like Unknown first word, if I recall correctly).

Obviously, the lack of location info is still an issue, though.

Screen Shot 2023-01-12 at 11.20.57

:thinking: Do you have this issue also when using npm run dev (bud dev)?
The one error may be caused by PostCSS (e.g. PostCSS minifier plugin), while the other is caused by the linter.

1 Like

Indeed, it seems to be the minifier plugin, as yarn run dev runs with no such error under the same conditions. Thanks, @strarsis, for bringing clarity to this one! I’m not super familiar with how Bud’s postcss package works, so whether this issue concerns Bud or is simply an upstream thing, I’m going ahead and marking your answer as the solution. Cheers!