Roots Discourse

Loading stylesheet

Hi,

I have installed the latest version of Sage using the Bootstrap preset and activated the theme. When I run yarn start my styles are not .injected. I get an error in the console:

Uncaught SyntaxError: Unexpected token <

This references line 1 of my webpage

I then tried yarn build and my stylesheet is created in the dist folder. However, the browser doesn’t load the stylesheet. I checked the source code of the page and clicked the link to the stylesheet but I get redirected to the homepage.

I then ran build:production and the page loaded the stylesheet.

Very confused as to what might be happening here if anyone can help?

Sounds like you haven’t configured things properly? Check your devUrl and publicPath

hey @showFocus, is you local running over https or http?

curious b/c I reverted to http (to debug an unrelated issue with a WP plugin), updated my configuration accordingly, and encountered the same console error on http.

when I switched back to https, the error disappeared.