Local Flywheel Development Origin?

I’m wondering how to properly set up “yarn dev” support on the following setup:

  • Latest Sage from dev-main
  • Bud 6.3.5
  • Normal WordPress install on Local by Flywheel
  • SSL enabled

I’m unsure what the appropriate serve settings should be and what URL it should be accessed through.

The default for this version of Sage is “https://0.0.0.0:3000” but I’ve also tried the previous format of “https://example.local:3000” with no luck.

Both result in a “This site can’t provide a secure connection” ERR_SSL_VERSION_OR_CIPHER_MISMATCH browser error

I have set my keychain certificate for example.local to “Always Trust”

Much thanks for any help you can provide.

You shouldn’t have to do a single thing besides define the proxy URL. Then you should be able to visit http://localhost:3000.

...

  .proxy("https://your-local-dev-url.here")
  .serve("http://0.0.0.0:3000")
  .setPublicPath("/app/themes/sage/public/");

After exhaustive testing using the setting you recommend, here’s what I’ve discovered.

Accessing through http://localhost:3000 does not work for me. I receive the following error

[proxy] › ✖  [HPM] Error occurred while proxying request localhost:3000/ to https://woodlands.local/ [ECONNREFUSED] (https://nodejs.org/api/errors.html#errors_
[proxy] › ✖  [HPM] Error occurred while proxying request localhost:3000/favicon.ico to https://woodlands.local/ [ECONNREFUSED] (https://nodejs.org/api/errors.h

If I restart my computer and use “yarn dev --browser” the browser opens at http://0.0.0.0:3000/ and everything works as expected sometimes. However, I’ve had this sequence not work from a fresh restart as well. Occasionally things will also just stop working as well.

When I do get that error it comes back in the same format as the previous

[proxy] › ✖  [HPM] Error occurred while proxying request 0.0.0.0:3000/ to https://woodlands.local/ [ECONNREFUSED] (https://nodejs.org/api/errors.html#errors_co
[proxy] › ✖  [HPM] Error occurred while proxying request 0.0.0.0:3000/favicon.ico to https://woodlands.local/ [ECONNREFUSED] (https://nodejs.org/api/errors.htm

Every time that happens I need to restart. I’ve tried ctrl+c to close out the script, closing out terminal altogether, and restarting local.

Also in my testing, I noticed if I restart and go to http://localhost:3000 first, I get the same error and the 0.0.0.0:3000/ address returns the error as well.

In addition, I’ve tried adding a favicon to the document root, and it makes no difference in the errors returned.

Thanks for any help on this,

I’m having the same issue when trying to work with “https” sites locally.

https://localhost:3000 won’t load.

Unfortunately I could not find any solution.

I’m using valet.

use http not https in config… For some reason I also cannot get it to work with https but http work just fine…

Are you saying for Local turn off the SSL for the domain?

yes, turn off ssl for localhost:300 where live preview will be shown…

.serve(“http://0.0.0.0:3000”)

and not

.serve(“https://0.0.0.0:3000”)

Currently, I’m serving from…

.serve("http://0.0.0.0:3000")

However, the site in Local is under the https protocol. With that setup, I’m still having issues. I will try a new site without SSL when I have a chance to see if that makes a difference.

Thanks @igor_sumonja,

Ditching SSL on Local by Flywheel site and setting both proxy and serve to “http” in the bud config resolved the issue for me.

Tnx.

Weird it does work for me if site itself is on https but I just need to serve proxy to http on localhost but I use Valet for my local dev so maybe that has some effect on it…