Local instalation of Sage giving build error with dependencies

We’ve cloned a repo and are trying to do a local installation using Wamp.

The project is using sage and bedrock .

I’ve already created a local database and created the .env correctly. Also ran composer install and yarn install inside project theme folder, and composer install on project root.

Successfully installed WP and logged to wordpress backoffice. Also activated the theme.

However the problem resides in the build. When I try to run yarn build (that does a bud build) I get an error “importing sass” (as shown on attachment number 1).

Tried to fix it but everytime I would run something to fix it gave a lot of warnings in dependencies so I ran a yarn check and it gave a HUGE list of errors (as seen in attachment number 2).

Don’t know if this helps but also on package.json the version on @roots/sage shows 6.8 (and I think Sage already is on 10 point something). Also attachment available (number 3).

Any help on what are the correct steps to install this project locally or to how I can fix that “importing sass” and something about that “sha1” error?