Roots Discourse

MacOS Monterey update: Can't vagrant up anymore, "mount.nfs: Connection timed out"

I just updated my MacBook to MacOS Monterey, and now I can’t vagrant up. This is as far as I get:

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Importing base box 'bento/ubuntu-18.04'...
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'bento/ubuntu-18.04' version '202110.25.0' is up to date...
==> default: Setting the name of the VM: example.test
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    default: Adapter 2: hostonly
==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
    default:
    default: Vagrant insecure key detected. Vagrant will automatically replace
    default: this with a newly generated keypair for better security.
    default:
    default: Inserting generated public key within guest...
    default: Removing insecure key from the guest if it's present...
    default: Key inserted! Disconnecting and reconnecting using new SSH key...
==> default: Machine booted and ready!
==> default: Checking for guest additions in VM...
==> default: Setting hostname...
==> default: Configuring and enabling network interfaces...
==> default: Exporting NFS shared folders...
==> default: Preparing to edit /etc/exports. Administrator privileges will be required...
==> default: Mounting NFS shared folders...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

mount -o vers=3,udp xxx.xxx.xx.x:/System/Volumes/Data/Users/matt/Sites/example.com/site /vagrant-nfs-example.com

Stdout from the command:



Stderr from the command:

mount.nfs: Connection timed out
  • Vagrant v2.2.10
  • Ansible v2.8.0
  • VirtualBox v6.1.30
  • Python 2.7.18

I’ve been doing a lot of searching, and found some solutions, but none of them are working for me. Here’s what I’ve done/tried:

  • iTerm has Full Disk Access and Accessibility permissions
  • Firewall is disabled
  • Disk encryption is disabled
  • VirtualBox updated to 6.1.30
  • Uninstalled/reinstalled Vagrant
  • Added “nfs_udp: false” to the Vagrantfile
  • installed the vagrant-vbguest plugin
  • Added /sbin/nfsd to Full Disk Access

Everything was working fine on Big Sur. I really don’t want to have to downgrade, I’ll have to manually reinstall everything again and that will take me soooo many hours.

Anyone else have some ideas for me to try?

Wow, after all these hours I finally figured it out.

Basically, you need to open trellis/vagrant.default.yml and update vagrant_ip from 192.168.50.X to 192.168.56.X. Just change the 50 to a 56.

That’s it.

One character!

aight I’m outta here bye

3 Likes

Hey @swalkinshaw I found this problem and fix the other day too. Is there any downside to adopting this change in Trellis?

Think I ran into this as well… so yeah we should probably just change the default for everyone.

2 Likes

After changing the IP, I get the following at vagrant up:

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["hostonlyif", "ipconfig", "vboxnet4", "--ip", "192.168.56.1", "--netmask", "255.255.255.0"]

Stderr: VBoxManage: error: Code E_ACCESSDENIED (0x80070005) - Access denied (extended info not available)
VBoxManage: error: Context: "EnableStaticIPConfig(Bstr(pszIp).raw(), Bstr(pszNetmask).raw())" at line 242 of file VBoxManageHostonly.cpp

I’m running VB 6.1.30, Extension Pack is current (though it took a few tries to install/update), and GuestAdditions seem to be working last time I actually got further than this error at vagrant up.

iMac is running Monterey 12.0.1.

When I roll back to *.*.50.*, this error goes away, but NFS won’t load…

Do I need to grant access to something somewhere?

Silly me…

For folks running into the same issue (as in my post directly above), try adding 192.168.56.0/21 or the equivalent to /etc/vbox/networks.conf.

1 Like