Mailhog not working on development

Hey guys

Thanks for any help i advance.

I’m having an issue with Mailhog on development.

When i try to access the site it displays a connecting refused message. I already tried with all browsers.

I do have SSL enabled on the dev site, but i was able to fix an issue where i was getting redirected to https by following these instructions: SSL and MailHog

I already updated to the latest version of Trellis, and Mailhog is running on the box but i get a connection refused message and can’t access it anymore.

It was working for me a couple of days ago, the only issue it had is that HTML emails were displayed incorrect, all content together without any spacing.

I want to add that doing this:

$ vagrant ssh
$ cd /opt/mailhog
$ ./mailhog

Makes it working again, so i guess maybe i’m missing some initialization somewhere on my trellis install ?

Anyway, any help with this will be highly appreciated.

Thanks in advance.

Did you also re-provision your server afterwards? If so, have you tried a vagrant destroy followed by a vagrant up?


Thanks for replying and sorry for the delay. Got pulled over to another project.

I did the destroy and up, but i get the same issue.

Not sure what’s causing.

If i find a solution i will post it here so if someone get the same issue.