Mailhog related issue when 'vagrant up'

Keep failing when ‘vagrant up’. rest of the process has passed but keep getting below message and won’t work yet. :frowning:

TASK [mailhog : Download MailHog and mhsendmail binaries.] *********************
System info:
Ansible; Vagrant 1.9.2; Darwin
Trellis at “Allow for per-project authentication”

failed to create temporary content file: (‘The read operation timed out’,)
failed: [default] (item={u’url’: u’’, u’dest’: u’/opt/mailhog/mailhog’}) => {“failed”: true, “item”: {“dest”: “/opt/mailhog/mailhog”, “url”: “”}}

1 Like

Related issue?

1 Like

As a first step, I’d just try vagrant provision again. It’s almost always a temporary issue with connectivity, or GitHub, something like that. – ref


Worked!!! Thanks! It was ansible issue!

1 Like

FYI also having the same issue today. Ran sudo vagrant provision 4 times with no difference. Previously it worked so hoping this is about connectivity but not sure.

failed to create temporary content file: ('The read operation timed out',)
failed: [default] (item={u'url': u'', u'dest': u'/opt/mailhog/mhsendmail'}) => {"failed": true, "item": {"dest": "/opt/mailhog/mhsendmail", "url": ""}}
	to retry, use: --limit @/Volumes/EKA2017/eka/eka-client/trellis/dev.retry

PLAY RECAP *********************************************************************
default                    : ok=36   changed=0    unreachable=0    failed=1   

Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.

EDIT: And 10 minutes later + deleting and updating dependencies it’s working again.

@krishaamer Just a guess, but it looks like your issue may have been that you were having trouble connecting to GitHub. It looks like it was trying to read from a remote URL and that read timed out.

1 Like