Modern Tribe Events Calendar stuck in responsive with older Roots theme

We use a much older version of Roots, before the theme wrappers, etc. Our problem is a bit different than the ones seen at Roots and Modern Tribe's Events Calendar for example.

Our theme stays stuck in the ‘responsive’ view, due to how Roots and TEC enqueue scripts it appears.

We have tried using their customize_tribe_events_breakpoint trigger, which sets the right number, but it never does anything (as in, I echo’d out the value, and its there, but their code seems to ignore it).

We have been getting support at , but they consider it a Roots issue, as it works in every other theme on our setup.

If you read from down to about line 700, you see how they enqueue, etc.

We are stuck on how to get around this. I am not sure if its the order things are getting set, etc.

Some debuging showed that the plugin (around line 688 in the link above) adds something like media="only screen and (max-width: 768px)" to the include. If I switch to another theme, this is included. If I am using Roots, this gets stripped out. What would cause that?

I found the issue, and created a fix. If anyone else runs into this, older versions of Roots used a roots_clean_style_tag function ( This would chop off the last part of the style tag, therefore removing the breakpoint that was needed. I added a new filter to allow this one through:

elseif ($matches[3][0] === 'only screen and (max-width: 768px)'){ $media = ' media="only screen and (max-width: 768px)"';

May make a minor update so it only checks for the first part of this, but it solved my issue.