Roots Discourse

Mount.nfs: access denied by server while mounting 192.168.50.1

This is probably not a Roots issue, however, seeing as it might impact somebody besides me I think it’s fair to post here in any case.

I tried to get a new install of Trellis running today and got stuck on this:

==> default: Mounting NFS shared folders...

The following SSH command responded with a non-zero exit status.

Vagrant assumes that this means the command failed!

mount -o vers=3,udp 192.168.50.1:/Users/my.name/WWW/Clients/Client\ Name/cms.client-name.com/site /vagrant-nfs-cms.client-name.com

Stdout from the command:

Stderr from the command:

mount.nfs: access denied by server while mounting 192.168.50.1:/Users/my.name/WWW/Clients/Client Name/cms.client-name.com/site

exit status 1

After some vagrant detroys manually pruning some entries in /etc/hosts and /etc/exports I finally tried changing the path of the project and I got it to work.

Seems like having a blank space in the client name, for some reason, breaks the mounting, so instead of having this path: /Users/my.name/WWW/Clients/Client Name/cms.client-name.com/ I changed it to: /Users/my.name/WWW/Clients/Client/cms.client-name.com/ and I was able to get it up and running.

Anyone know of a work around? Looks messy to force ClientName or using just half of the client name…

Literally just signed up to say thank you for pointing out that it could be caused my space in a directory. None of the other solutions worked. I’'d never have thought. Thank you so much.

1 Like