Mounting NFS Issue on Mac


I have been having some trouble setting up trellis on my Mac and I feel like I have tried everything I have found on github issues and stack overflow. Most of the problems are from quite a long time ago so I am wondering if I need to change something else.

My setup is

  • OS X El Capitan v 10.11.3
  • Vagrant 1.8.1
  • ansible
  • Oracle VirtualBox 5.0.14

I am having an issue with running vagrant up and getting the following error

==> default: Mounting NFS shared folders...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

mount -o 'vers=3,udp''/Users/rossdallaire/Projects/METER/meter-core/site' /vagrant-nfs-meter

Stdout from the command:

Stderr from the command:

mount.nfs: requested NFS version or transport protocol is not supported

I have tried

  • Changing versions of Vagrant/ Ansible
  • changing various lines in my config to add permissions to folders
  • some other commands from stack overflow

so far with no luck.

Here is my vagrant file

Edit I originally had thought I fixed this with rsync but it was not syncing properly. Still looking for solutions


Interesting. Still no reply almost a year later. This is my 3rd attempt at Trellis, and a 3rd failed one. I can see that people here don’t really want to support the users.

1 Like

This seems to be rather a vagrant specific issue,
check the lasts posts there for solutions:

Alterntaively use samba/CIFS instead NFS, I also switched to it on a Windows/Linux combination and it works - and it isn’t necessarily slower.