Need a Developer to Verify Caching is Working on my Site and Setup Remote Debugging for PHPStorm


I have 2 tasks – one involves helping me understand and/or fix a caching issue on my site, the other is helping me so I can troubleshoot production using xdebug.

I’d pay a developer $85 per hour to help me fix/understand this.

I have a Wordpress/Bedrock/Trellis site using Nginx and PHP-FPM.

  1. When updating a php file on my site that is not supposed to be cached, I’m noticing that there is a delay in having it update. I’m wanting caching to be disabled for woocommerce and for a page /my-transcripts
 enabled: true
 duration: 1s
 skip_cache_uri: /wp-admin/|/xmlrpc.php|wp-.*.php|/feed/|index.php|sitemap(_index)?.xml|/store.*|/cart.*|/my-account.*|/checkout.*|/addons.*|/my-transcripts.*
 skip_cache_cookie: comment_author|wordpress_[a-f0-9]+|wp-postpass|wordpress_no_cache|wordpress_logged_in|woocommerce_cart_hash|woocommerce_items_in_cart|wp_woocommerce_session_

I have this in my sites-enabled under /etc/nginx

Fastcgi cache conditions

set $skip_cache 0;
if ($query_string != “”) {
set $skip_cache 1;
if ($request_uri ~* "/wp-admin/|/xmlrpc.php|wp-..php|/feed/|index.php|sitemap(_index)?.xml|/store.|/cart.|/my-account.|/checkout.|/addons.|/my-transcripts.") {
set $skip_cache 1;
if ($http_cookie ~
“comment_author|wordpress_[a-f0-9]+|wp-postpass|wordpress_no_cache|wordpress_logged_in|woocommerce_cart_hash|woocommerce_items_in_cart|wp_woocommerce_session_”) {
set $skip_cache 1;

I notice that even with this code or disabling the cache I still have the following errors in Woocommerce:

The issue is if I add 5 gallons of Ancient Humate to my cart – I then select California as the state first with no address, then add my full Colorado address, then change the pickup to Fedex. The sales tax still shows up. You need to putting in the full address – you need to put more than the state. Please put street, state, zip, country when testing this.

The woocommerce people are thinking I have a caching issue as I submitted a ticket to them.

I also notice that if I update the my-transcripts.php that it takes up to a minute to reload. However, if I restart the php-fpm service it reloads right away.

I need to address and/or understand both these issues. I’ve tried to disable caching and played around with a lot of settings with no luck.

  1. I need help setting up phpstorm with xdebug on a remote server so I can debug my production site.

I’ve followed these instructions:

And I have PHPStorm setup so it works to debug my local vagrant instance – so I know its working as going into Firefox using firebug opens the breakpoint in PHPStorm.




Try change the config to this:

skip_cache_uri: /wp-admin/|/xmlrpc.php|wp-.*.php|/feed/|index.php|sitemap(_index)?.xml|/store|/cart|/my-account|/checkout|/addons|/my-transcripts

Note that .* are being removed.


This will exclude all urls starts with from caching, for example:

You might want to recheck about excluding /store