Need help with a certificate renewal

Hello, I need help with a certificate renewal. I have to revive a project that has been staging for a year. I don’t know why, the certificate is not renewed.

I can provision the server and deploy with no problem, but the certificate still doesn’t work.

The site is currently accessible from chrome. If the insecure option is accepted, it lets you access:

Also if I try to renew with certbot I get this error.

No certificate found with name (expected /etc/letsencrypt/renewal/

In fact, the /etc/letsencrypt/renewal/ directory appears empty on the server.

What can I do to renew the certificate? Thanks a lot for the help, I’m a bit lost.

This is group_vars/staging/wordpress_sites.yml:

      - canonical:
    local_path: ../arte-conocimiento
    branch: main
      enabled: false
      enabled: true
      provider: letsencrypt
      enabled: true
      skip_cache_uri: /wp-admin/|/xmlrpc.php|wp-.*.php|/feed/|index.php|sitemap(_index)?.xml
      skip_cache_cookie: comment_author|wordpress_[a-f0-9]+|wp-postpass|wordpress_no_cache|wordpress_logged_in

I removed the SSL for the moment. It is in staging, so it is no serious. But if anyone has an explanation, it would help me to know what’s going on with the certificate.

Hm, I visited your URL about 10 minutes ago and the certificate worked fine (was not even expired),
no warnings (insecure) and such - it worked perfectly fine.

Now an outdated certificate is used. Just being sure, are you SSH’ed into the right system?

1 Like

It’s early in the morning, but your canonical domain doesn’t match what’s in the error. Did DNS change in the time this project was on hold?

The error:

Your staging config:

Yes, sorry! I put everything in the translator, including terminal output. :grimacing: :sweat_smile: It is fixed now!

Deploying with SSL enabled: false and deploy again with enabled: true worked.