Roots Discourse

Need quick fix--some Memberpress plugin templates not working

I’m banging my head against the wall trying to get Memberpress plugin templates to work completely with Sage 9. Everything works fine with Sage 8, so this may have to do with blade, which is new for me. A few people have given some suggestions and I’ve tried figuring it out on my own, but I don’t have the dev skills.

I had a similar problem with bbpress, and this fixed it:

Another person may have had a similar problem with buddypress. Solution here:

I’m wanting to fix the problem and also understand how it was fixed so I can learn and use blade correctly, and it seems like there is a fix out there.

Within Memberpress, there are some slugs for “plans” and “register” (see screenshot below) specified under “Group and Membership Page Slugs”, which seem to be the only pages that don’t work.

I have verified that using shortcodes instead is working. Not sure if that would be considered a slightly hacky workaround. I’d prefer to have a good understanding of sage 9 and blade usage.

Hi ,
I am a experienced developer and would be able to help you out on this…
You can reach me on
Best Wishes,

He hello @eric_gauvin, did you already fond a solid solution for Memberpress and Sage 9?


Add a filter.

1 Like