Roots Discourse

NFS Shared Folders failing to mount on macOS Mojave + Virtualbox 6.0


#1

I bought a new MacBook Pro a just few days ago that is running Mojave and has an encrypted SSD. I followed the Trellis documentation for getting set up, but NFS shared folders are failing to mount. I’ve found Discourse threads about this issue occurring on Ubuntu hosts with encrypted home directories, but not with a Mac host machine. Hoping someone can provide some guidance.

I have these installed:

  • Virtualbox 6.0
  • Vagrant 2.2.2
  • Ansible 2.2.1.0

Vagrant plugins:

  • hostmanager (1.2.2, global)
  • landrush (1.3.1, global)
  • vagrant-bindfs (1.1.0, global)

Notes / things I’ve tried:

  • Based on the /trellis/CHANGELOG.md, file in the project, it looks like we are using Trellis 0.9.9, along with some of the newer commits that were a part of 1.0.0-rc.1.
  • I’ve tried restarting my computer, vagrant reload --provision, and vagrant destroy -f && vagrant up several times.
  • On my previous Mac that was running Mojave, but did not have an encrypted SSD, I had the project up and running without any issues. I’m not sure what versions of Virtualbox, Vagrant, etc. it was running though since that machine is no longer operable.
  • On my previous Mac, I had been able to run vagrant plugin install bindfs to install the bindfs plugin. On my new machine, that command yields Unable to resolve dependency: user requested 'bindfs (> 0)', so I had to run vagrant plugin install vagrant-bindfs instead. Not sure if that matters, but I want to include it here for completion.
  • I noticed that the command line output when running a vagrant up said “The guest additions on this VM do not match the installed version of VirtualBox! In most cases this is fine, but in rare cases it can prevent things such as shared folders from working properly.” Based on that, I went to Applications > Virtualbox > Show package contents > Contents > MacOS > VBoxGuestAdditions.iso, mounted that, then ran the VBoxDarwinAdditions.pkg and walked through the wizard to install the Guest Additions for MacOS.
  • In the Virtualbox documentation, I noticed that “disk encryption” is listed as one of the features of the VirtualBox 6.0.0 Oracle VM VirtualBox Extension Pack, so I went ahead and installed that, as well.

Command line output when running a vagrant up:

==> default: Exporting NFS shared folders...
==> default: Preparing to edit /etc/exports. Administrator privileges will be required...
Password:
tee: /etc/exports: Operation not permitted
tee: /etc/exports: Operation not permitted
tee: /etc/exports: Operation not permitted
tee: /etc/exports: Operation not permitted
The nfsd service does not appear to be running.
Starting the nfsd service
==> default: Mounting NFS shared folders...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

mount -o vers=3,udp 192.168.50.1:/Users/kellen/Sites/harness-wordpress-app/site /vagrant-nfs-harnessup.com

Stdout from the command:


Stderr from the command:

mount.nfs: Connection timed out

Thanks in advance for any help you’re able to give.


#2

Update:

I determined that the /etc/exports: Operation not permitted lines above were due to the fact that iTerm, my command line app did not have full disk access. I followed these steps
(https://github.com/hashicorp/vagrant/issues/10234#issuecomment-424305964) to grant that app full disk access in macOS’ Security & Privacy settings, which fixed this issue for me.

This thread can now be closed out.