Nginx not installed after running succesfully "vagrant up"

Hi, I´ve followed the documentation to install trellis on a local linux machine, and after running “vagrant up” I get a success message:
==> default: Your Trellis Vagrant box is ready to use!
and some info about vagrant ssh and the location of Wordpress sites.

The next thing I do is trying to open my brand new wordpress installation on my browser, to no avail. I checked my /etc/hosts to make sure I was entering the right url.

Then I run “vagrant ssh” and I search for the wordpress files. And /srv is an empty folder. Also I check the nginx status, and to my surprise, it isn´t an existing service on the VM.

Then I run apt-get install nginx, and I can see its welcome page on but /srv/ is still an empty folder, and I am a bit lost. Wasn’t nginx supposed to be already up and running? What do I do now to get a wordpress site running on trellis?

I´ve got ansible 2.6.3, virtualbox 5.1.38 and vagrant 2.1.2 installed. Thanks

It sounds like maybe you didn’t install Bedrock. See the documentation here, specifically bullet 3, “Clone Bedrock”:

hi, thanks for the early reply. I have installed Bedrock. I did clone both trellis and bedrock from the github repository, and on my host machine bedrock is within a folder called “site”. Folder and files permissions are similar to those on the trellis folder, and are owned by the same user, the one who run vagrant up.

Can you try a vagrant destroy && vagrant up and watch for errors during the process?

What operating system are you using on your host?

It works!
I´m using linux mint. Apparently it was a firewall issue. When trying the vagrant destroy && vagrant up I would get a time out error when mounting nfs. After disabling the firewall that error didn´t show again, and the whole lemp stack got installed. But yet I could not access my brand new wordpress installation on my browser. A new vagrant destroy && vagrant up made it work. I got some warnings, related to ansible version being too new tho.

Thanks MWDelaney for your support. Now I need to figure out how to configure my firewall, but that seems out of the scope of this forum. Cheers