Nice-search on IIS - Recieve 404 Error when searching more than one word

When I search one of my wordpress sites using roots with more than one word I receive a 404 error. I am currently running Wordpress on a iis server with multi sites enabled.

Have you tried one of the default WordPress themes to see if the issue persists?

Also try disabling nice-search in lib/config.php (if you are using an older version of Roots).

Other themes work fine. It is only when I use Nice Search. This has always been a problem with Roots though and Nice Search for me. I thought eventually it would get fixed but the problem still persist.

Debugging on IIS and/or in a multisite environment is unlikely. Even more so given that nice-search is a non-essential feature, that’s easily disabled and has already been moved from the starter theme to our Soil plugin.

It’s likely to be a rewrites or encoding issue if you want to give fixing it a try yourself.