No dist folder on start

I have a apache running via XAMPP. In my htdocs I have different wordpress sites. For the second time I am setting up one with Sage 9. The first time (9.0.0-beta.2) it worked quite well, but I don’t get the second one (9.0.0-beta.3) up and running.

The problem seems to be that the build folder does not get created on yarn run start.

When Browsersync opens the site, I see http://localhost:3000/ref/but the css does not get injected and the scripts.js file is not found (well I guess because there is no dist folder)
Also, when I click on a link (e.g. a page or a post) a empty site opens. Earlier i was redirected to XAMPP Dashboard, but I disabled that in the htdocs/index.php file.

Here’s my config:
{ "entry": { "main": [ "./scripts/main.js", "./styles/main.scss" ], "customizer": [ "./scripts/customizer.js" ], "scripts": [ "./scripts/scripts.js" ] }, "publicPath": "/ref/wp-content/themes/ref/", "devUrl": "http://localhost/ref/", "proxyUrl": "http://localhost:3000", "cacheBusting": "[name]_[hash:8]", "watch": [ "{app,resources/views}/**/*.php" ], "browsers": [ "last 2 versions", "android 4", "opera 12" ] }

I feel like I might be doing something wrong here.

btw: The scripts.js file is located in the resources/assets/scripts folder and is enqueued in the setup.php. I don’t think that this is the source of the problem.

Do you see what I’m doing wrong? If you need any further information, let me know.

I was having the same issues and they did indeed have changed some things around. Here is an excerpt from an email I received today actually.

Sage 9 Beta 3 was released the other week, with the notable changes being:
Moved required theme files to sage/resources/
Moved src/ to app/
Moved templates/ to resources/views/
Moved assets/ to resources/assets/
Go grab the latest Sage 9 and let us know your thoughts! Controller has also been updated to support the latest beta.
Trellis 1.0.0 RC1 is out and includes several improvements and new features. Take a look at the changes, but also note the updates that have landed since the RC, such as the new Vagrant config!

I am still playing with it myself and learning the new setup. Hope this helps!

Thx for the info. Yes I did realize that some files were not in the same place anymore. But does this also have an impact on the config. I’d be really happy if someone could help me with this as I cannot continue working on my theme like this.

I found the error. The dist folder was not created because of a sass error:

Module build failed: $link-hover-color: darken($link-color, 15%) !default; ^ Argument '$color' of 'darken($color, $amount)' must be a color

I saw the error when I tried to run build. Running start did not throw this error.
The error itself was because I tried to set $link-color: to inherit;. Bootstrap tried then to darken this value which was not possible as it is not a colour.