No gulpfile found

I would really appreciate any advice anyone can give me. I have followed all the steps from the PDF guide and I also purchased the video which I followed step by step. However, as soon as I try to run gulp, I get the error" No gulpfile found".

I’ve tried every solution I can find through Google search, I’ve deleted and reinstalled the theme, I’ve installed node.js 3 times, I’ve gone through every other step at least 2-3 times to ensure that I didn’t miss anything, but no whatter what, nothing is working.

Can someone please help me?

Sage 9 is being prepped and tested. It’s currently the master branch. Sage 8 used gulp, and is still the “stable” build. Use the sage-8 branch or a tagged release.


Thank you so much!

I followed the instructions and tried to continue with sage 9, however I’m now getting a persistent error:

ERROR in ./styles/main.scss
Module build failed: ModuleBuildError: Module build failed: Error: Cannot find module ‘node-sass’

And as a result, I can’t compile my css.

I’ve installed node-sass many times. Any ideas what I might be doing wrong here? My apologies if I’m just ignorant as I’m still learning how to use npm etc.

Don’t worry, problem solved. Thanks again!

Hi, what was the solution to the problem? I am having similar issues.