"No such file or directory" on [setup] Task

Hello,

I try to deploy with trellis to strato. But the Task [setup] fails:

PLAY [Deploy WP site] **********************************************************

TASK [setup] *******************************************************************
<ssh.strato.de> ESTABLISH SSH CONNECTION FOR USER: my_user
<ssh.strato.de> SSH: EXEC ssh -C -vvv -o ForwardAgent=yes -o ControlMaster=auto -o ControlPersist=60s -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o User=my_user -o ConnectTimeout=10 -o ControlPath=/Users/js/.ansible/cp/ansible-ssh-%h-%p-%r -tt ssh.strato.de '/bin/sh -c '"'"'( umask 22 && mkdir -p "` echo $HOME/files/trellis_temp/ansible-tmp-1466418064.97-270522037713915 `" && echo "` echo $HOME/files/trellis_temp/ansible-tmp-1466418064.97-270522037713915 `" )'"'"''
<ssh.strato.de> PUT /var/folders/d9/96crrf8s7r393vwy5x_7fnym0000gp/T/tmpDfVgB2 TO /mnt/webo/c3/69/12345677/htdocs/files/trellis_temp/ansible-tmp-1466418064.97-270522037713915/setup
<ssh.strato.de> SSH: EXEC scp -C -vvv -o ForwardAgent=yes -o ControlMaster=auto -o ControlPersist=60s -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o User=my_user -o ConnectTimeout=10 -o ControlPath=/Users/js/.ansible/cp/ansible-ssh-%h-%p-%r /var/folders/d9/96crrf8s7r393vwy5x_7fnym0000gp/T/tmpDfVgB2 '[ssh.strato.de]:/mnt/webo/c3/69/12345677/htdocs/files/trellis_temp/ansible-tmp-1466418064.97-270522037713915/setup'
fatal: [ssh.strato.de]: FAILED! => {"failed": true, "msg": "failed to transfer file to /mnt/webo/c3/69/12345677/htdocs/files/trellis_temp/ansible-tmp-1466418064.97-270522037713915/setup:\n\nExecuting: program /usr/bin/ssh host ssh.strato.de, user (unspecified), command scp -v -t /mnt/webo/c3/69/12345677/htdocs/files/trellis_temp/ansible-tmp-1466418064.97-270522037713915/setup\nOpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011\ndebug1: Reading configuration data /Users/js/.ssh/config\r\ndebug1: /Users/js/.ssh/config line 1: Applying options for *strato.de\r\ndebug1: Reading configuration data /etc/ssh_config\r\ndebug1: /etc/ssh_config line 20: Applying options for *\r\ndebug1: auto-mux: Trying existing master\r\ndebug2: fd 3 setting O_NONBLOCK\r\ndebug2: mux_client_hello_exchange: master version 4\r\ndebug3: mux_client_forwards: request forwardings: 0 local, 0 remote\r\ndebug3: mux_client_request_session: entering\r\ndebug3: mux_client_request_alive: entering\r\ndebug3: mux_client_request_alive: done pid = 26011\r\ndebug3: mux_client_request_session: session request sent\r\ndebug1: mux_client_request_session: master session id: 2\r\nSending file modes: C0600 212533 tmpDfVgB2\nscp: /mnt/webo/c3/69/12345677/htdocs/files/trellis_temp/ansible-tmp-1466418064.97-270522037713915/setup: No such file or directory\n"}

I have scp_if_ssh=True enabled in ansible.cfg, because sftp is not available on strato.

I deployed the same project to Mittwald (another hoster), and it worked without problems.

Does sombeody have an idea on what could be wrong?

Ok, updated trellis and ansible to current version, got a better error description now:

TASK [setup] *******************************************************************
<ssh.strato.de> ESTABLISH SSH CONNECTION FOR USER: my_user
<ssh.strato.de> SSH: EXEC ssh -C -vvv -o ForwardAgent=yes -o ControlMaster=auto -o ControlPersist=60s -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o User=my_user -o ConnectTimeout=10 -o ControlPath=/Users/js/.ansible/cp/ansible-ssh-%h-%p-%r -tt ssh.strato.de ‘/bin/sh -c ‘"’"’( umask 22 && mkdir -p “echo $HOME/.ansible/tmp/ansible-tmp-1466425726.56-200029455040436” && echo “echo $HOME/.ansible/tmp/ansible-tmp-1466425726.56-200029455040436” )’"’"’’
<ssh.strato.de> PUT /var/folders/d9/96crrf8s7r393vwy5x_7fnym0000gp/T/tmpOgioxw TO /mnt/webo/c3/68/12345677/htdocs/.ansible/tmp/ansible-tmp-1466425726.56-200029455040436/setup
<ssh.strato.de> SSH: EXEC sftp -b - -C -vvv -o ForwardAgent=yes -o ControlMaster=auto -o ControlPersist=60s -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o User=my_user -o ConnectTimeout=10 -o ControlPath=/Users/js/.ansible/cp/ansible-ssh-%h-%p-%r '[ssh.strato.de]'
System info:
Ansible 2.0.1.0; Darwin
Trellis at “Fix #468 - Use curl to install wp-cli tab completions”

failed to transfer file to /mnt/webo/c3/68/12345677/htdocs/.ansible/tmp
/ansible-tmp-1466425726.56-200029455040436/setup:
sftp> put /var/folders/d9/96crrf8s7r393vwy5x_7fnym0000gp/T/tmpOgioxw
/mnt/webo/c3/68/12345677/htdocs/.ansible/tmp/ansible-
tmp-1466425726.56-200029455040436/setup
Uploading /var/folders/d9/96crrf8s7r393vwy5x_7fnym0000gp/T/tmpOgioxw to
/mnt/webo/c3/68/12345677/htdocs/.ansible/tmp/ansible-
tmp-1466425726.56-200029455040436/setup

OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /Users/js/.ssh/config
debug1: /Users/js/.ssh/config line 1: Applying options for
*strato.de
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: auto-mux: Trying existing master
debug2: fd 3 setting O_NONBLOCK
debug2: mux_client_hello_exchange: master version 4
debug3: mux_client_forwards: request forwardings: 0 local, 0 remote
debug3: mux_client_request_session: entering
debug3: mux_client_request_alive: entering
debug3: mux_client_request_alive: done pid = 36066
debug3: mux_client_request_session: session request sent
debug1: mux_client_request_session: master session id: 2
debug2: Remote version: 3
debug3: Sent message fd 9 T:16 I:0
debug3: SSH_FXP_REALPATH . -> / size 0
debug3: Looking up /var/folders/d9/96crrf8s7r393vwy5x_7fnym0000gp/T/tmpOgioxw
debug3: Sent message fd 9 T:17 I:1
debug3: Received stat reply T:101 I:1
debug1: Couldn’t stat remote file: No such file or directory
debug3: Sent message SSH2_FXP_OPEN I:2
P:/mnt/webo/c3/68/12345677/htdocs/.ansible/tmp/ansible-
tmp-1466425726.56-200029455040436/setup
remote open("/mnt/webo/c3/68/12345677/htdocs/.ansible/tmp/ansible-
tmp-1466425726.56-200029455040436/setup"): No such file or directory
debug3: mux_client_read_packet: read header failed: Broken pipe
debug2: Received exit status from master 0

fatal: [ssh.strato.de]: FAILED! => {“failed”: true}

Your Ansible version should be 2.0.2.0

Thank you.

Installed 2.0.2.0. Same error.

Does somebody have another idea?

One thing: When you connect to ssh.strato.de, the username “mydomain.de” is used, so you connect with> ssh mydomain.de@ssh.strato.de. But on the server, the user has no username, only an id. Could it be, that this is not working for ansible playbook?

Does somebody have an idea for better debugging this?

Ok, I had to put relative ansible remote temp path to my configuration.