Node version requirement by Sage 9


What is the requirement of Sage 9?
I got some issues with having to new Node, which gives me troubles. Node-sass etc.

So having a to modern use of Node is not the best, which version is Sage made for?

1 Like

It is helpful to use a tool like nvm to manage the node version to be used:

The documentation states >=8.0.0, so I’d start around there. Usually the LTS version (current 12) is also a good bet.

w/r/t to node-sass you can sometimes resolve problems there by switching to sass (the reference implementation in Dart). It’s fairly straightforward unless you’ve got some major customization to you build process: Remove node-sass from your dependencies and add sass–they use compatible APIs. Sometimes you need to change the implementation value in your sass-loader definition to make sure Webpack knows which one to use. IME Dart SASS has been a lot easier to work with (way fewer problems w/ npm install).

If I raised the version of Node-sass to 4.13.0, I was able to build it with node v12.18.3.

This topic was automatically closed after 42 days. New replies are no longer allowed.