Roots Discourse

Oh my god, it works. It all works

I have managed to get everything working, I believe.

On Windows 7.

Trellis, Bedrock, Sage. Everything works. All of the Trellis deploys work, Bedrock works, Sage works.

I ran gulp --production on local to create the theme assets. Then I ran the two ansible deploy commands (the server.yml one and deploy.sh), and then I copied the database over after doing a find/replace on it.

But it works. Now my site from my local vagrant dev environment is up on my staging server (subdomain on a digital ocean droplet).

So if anyone is using Windows and trying to get all this shit to work, feel free to shoot me a question. Honestly this has been such an ordeal that I think it would take me a week or so to get it all down in writing, but at this point I feel qualified to help someone in a similar situation.

Sorry if this is off topic, I just can’t believe I finally managed to get EVERYTHING working end-to-end, and although I was able to find what I needed across the various topics in this forum (great info all over this place), I definitely had to do some searching. So hopefully I’ll be able to “put it all in one place” for anyone running into the issues I’ve had to deal with getting this all figured out.

5 Likes

Good to hear! I always find Windows setup to be a pain.

Speaking of, I did a fresh install of Roots Sage into my Win10 comp. I ran all the usual commands then ran gulp watch. All works fine except my CSS path is incorrect, it’s missing my root folder name. So currently it is showing as:

<link rel="stylesheet" href="/content/themes/our-theme/dist/styles/main.css">

Have you seen this before / any ideas of a fix?

Thanks!

:confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball: :confetti_ball:

OK party’s over. Now you are in charge of maintaining support for windows until further notice.

6 Likes

Can you check the return of get_template_directory_uri() when Assets\asset_path() is called at the bottom of lib/setup.php? If that’s working correctly (returning the full path), I’d say you could narrow your search down to just the files in the lib folder.

If not, it’s probably an issue with Bedrock. Are you using Bedrock?

Ah I managed to fix it myself, turns out I had to define the WP_CONTENT_URL to my localhost address in my local-config.php.

Thanks for the tip though!