Page isn't working - initial setup

Hello roots community,

In advance: I’ve also noticed as a new user, I can only have two images in the post (and 4 links), I thought it worthwhile to show as much info as possible, as such I’ve used a combination of the two.

I’m having an issue where the Wordpress site is not appearing, instead it’s showing me:

I’ve tried my google-fu and attempted a few things, including:

  1. Opting to use .test opposed to .dev
  2. vagrant ssh and check:
    • If I can vagrant ssh (success)
    • cd into /srv/www/ and checked logs (access and error.log). If I cat the two files I get a blank, presumably that’s ideal
    • If I run: sudo service nginx status I get the following: Image 2018-08-22 at 9.28.09 am
      Which seems to be operating correctly

To further diagnose the issue I’ve checked that vagrant hostmanager is doing it’s thing in /etc/hosts, which seems to be okay: Image 2018-08-22 at 9.27.39 am

When I ping example.test (which is the canonical url in development/wordpress_sites.yml) I get the following: Image 2018-08-22 at 9.26.12 am

When I curl example.test I get: Image 2018-08-22 at 9.26.44 am

That’s the only slightly negative thing I have run into while looking for any clues and even so, that makes sense.

I’m unsure on where to go with this at the moment, any help would be greatly appreciated.


It almost seems like you’re not serving any pages. Did you complete the steps on this page including cloning Bedrock?

I did follow those instructions - what I have at the moment looks like:

Did I have to add any ‘new’ content to Bedrock? At the moment it has been simply cloned across, via $ git clone --depth=1 site && rm -rf site/.git


Did you initially set up the site with a .dev URL? If so, did you follow every step of this guide:

Also, when you do ssh into Vagrant box, does WP-CLI work? Perhaps, run something like wp option get home. That’s should tell you what the URL WordPress is set to use.

Think your on to something knowler, doing wp option get home gives me:

I seem to have missed that in the setup… how should I proceed? Best bet would be to run through the requirements again?


You need to run that inside of the site’s directory on the server. So something like /srv/www/

If you haven’t started dev, you’ve got nothing to lose from restarting.

Try running composer install from inside your /srv/www/ directory. I wonder if that didn’t run during provisioning somehow.

1 Like

Brilliant, that has done it!

Having run vagrant destroy and confirmed that composer was installed correctly globally. I ran vagrant up again.

Thanks for your help @knowler and @MWDelaney :+1:


1 Like