Roots Discourse

Particles.js error 'particlesJS' is not defined

I’ve been trying to integrate particles.js into my theme., however, I keep running into the error "error ‘particlesJS’ is not defined"

  • particles.js successfully included with yarn add particles.js
  • import ‘particles.js’ in main.js

The error actors when I go into my home.js file, and right under the line export default { init() { I start to insert my app.js file content, and the error is output.

I can’t seem to find a successful way to include particles into sage, I’m able to make it work on a any other Wordpress theme I create.

Not sure but maybe this could help you, try it.

import 'particles.js/particles';
const particlesJS = window.particlesJS;
particlesJS.load('particles-js', 'particles.json', null);

This compiles, however now I receive a number of other errors

  • Error pJS - XMLHttpRequest status: 404
  • particles.js:1535 Error pJS - File config not found

I’m not familiar w/ the library, but the above looks like it’s failing to load your configuration file.

particlesJS.load('particles-js', 'particles.json', null);

If you’re using that code, it’s looking for a file called particles.json. Does that file exist, and in the location where the script is looking for it?

It’s been a year since I looked at Particles.js within sage. (and i wasn’t too great at using sage 9 / local Wordpress at that point). If i Remember correct, Chrome doesn’t allow Ajax calls to local Json files? so it might not work until you load it up.

Hi,

@Collin_Berg @Collin_Berg

I have solution how to add particles.js in sage theme, it’s nasty but works :slight_smile:
Below quick tutorial.

1. Install package - yarn add particles.js
2. Create new js file in …/resources/assets/scripts/myexample.js
3. In config.json add our file myexample.js

"myexample":[
  "./scripts/myexample.js"
]

4. Regsiter this script in setup.php

wp_enqueue_script(‘sage/myexample.js’, asset_path(‘scripts/myexample.js’), [‘jquery’], null, true);

5. Now, this nasty part because in our new js file we have to disable eslint

import ‘particles.js/particles’;

$(document).ready(function(){
/* eslint-disable */

particlesJS(‘particles-js’,
{
“particles”: {
“number”: {
“value”: 160,
“density”: {
“enable”: true,
“value_area”: 800
}
},
“color”: {
“value”: “#ffffff
},
“shape”: {
“type”: “circle”,
“stroke”: {
“width”: 0,
“color”: “#000000
},
“polygon”: {
“nb_sides”: 5
},
“image”: {
“src”: “img/github.svg”,
“width”: 100,
“height”: 100
}
},
“opacity”: {
“value”: 1,
“random”: true,
“anim”: {
“enable”: true,
“speed”: 1,
“opacity_min”: 0,
“sync”: false
}
},
“size”: {
“value”: 3,
“random”: true,
“anim”: {
“enable”: false,
“speed”: 4,
“size_min”: 0.3,
“sync”: false
}
},
“line_linked”: {
“enable”: false,
“distance”: 150,
“color”: “#ffffff”,
“opacity”: 0.4,
“width”: 1
},
“move”: {
“enable”: true,
“speed”: 1,
“direction”: “none”,
“random”: true,
“straight”: false,
“out_mode”: “out”,
“bounce”: false,
“attract”: {
“enable”: false,
“rotateX”: 600,
“rotateY”: 600
}
}
},
“interactivity”: {
“detect_on”: “canvas”,
“events”: {
“onhover”: {
“enable”: true,
“mode”: “bubble”
},
“onclick”: {
“enable”: true,
“mode”: “repulse”
},
“resize”: true
},
“modes”: {
“grab”: {
“distance”: 400,
“line_linked”: {
“opacity”: 1
}
},
“bubble”: {
“distance”: 250,
“size”: 0,
“duration”: 2,
“opacity”: 0,
“speed”: 3
},
“repulse”: {
“distance”: 400,
“duration”: 0.4
},
“push”: {
“particles_nb”: 4
},
“remove”: {
“particles_nb”: 2
}
}
},
“retina_detect”: true,
“config_demo”: {
“hide_card”: false,
“background_color”: “#b61924”,
“background_image”: “”,
“background_position”: “50% 50%”,
“background_repeat”: “no-repeat”,
“background_size”: “cover”
}
}
);
/* eslint-enable */
});

6. Add this css
/* PARTICLES */
#particles-js {
position: absolute;
width: 100%;
height: 100%;
background-color: #232741;
}

7. Add html element wherever you want <div id="particles-js"></div>
8. yarn build

1 Like

Thanks!

Just implemented it and got it working. I think my initial attempts were made before i knew how to mess around with the eslint settings a few years ago, and calling a json file doesn’t seem to work anymore with chrome locally.

Thanks man!

No problem, I’am glad I could help :slight_smile: