Permalink problem after trellis deploy

Hi there,

I started last week a new project using Trellis, Bedrock and Sage. Everything was pretty fine until today. I deployed my brand new website without any problems on a DigitalOcean droplet but I finally got a problem:
I’m not able to reach two specific pages I created (page-about.php and page-academic.php, see repo) online.

My website is:
My website repo is:

I’m pretty sure the solution is easy but I worked on that all day long and it’s driving me nuts. I wasn’t able to find any topic related to that on Discourse.

Could you help me please? I will appreciate any help/suggestion :slight_smile:


Have you tried re-saving your permalinks?

Can you confirm that those pages exist on the deployed site? Trellis doesn’t copy or import the database from your development environment. If you didn’t do that, or create those pages manually after deploy, they won’t be there yet.

1 Like

The pages were duplicated directly from Sage starting theme (duplicating page.php into page-about.php and page-academic.php as shown in the repo).

How can I check that they are actually on my droplet? Through ssh?

I am really a beginner with this deploy process but I really enjoy Trellis :slight_smile:

Creating those files creates the templates, not the actual pages in WordPress. Log into WordPress and create a page titled “About”, and another titled “Academic”.

1 Like

Thanks a lot!!! Makes sense!

It worked perfectly :blush:

Thank you so much!