Phpmyadmin on dev box

I’m trying to setup phpmyadmin on vagrant box, but it eludes me.
I tried both symbolic link and virtual host installation.
When I visit /phpmyadmin it either gives me 502, or starts downloading index.php from phpmyadmin folder.
What I’ve found from default server block is that vagrant’s virtual host uses php5-fpm-wordpress.sock, and i’ve looked in /run directory for the regular php5-fpm.sock but there isn’t any, only and php5-fpm-wordpress.sock.

phpMyAdmin? :-1:

What operating system are you on? Highly recommend Sequel Pro for OS X users.


Sorry, forgot to mention. I’m using Windows 10 host, Ubuntu trusty64 virtual machine.
I’m trying to setup phpmyadmin because I have a large phpmyadmin db dump that doesn’t get imported correctly through mysql command.

@Ivan_Svaljek really weird that a dump wouldn’t import without phpmyadmin. Database dump are standards and should be loadable without going through phpmyadmin.

On window, you could try Mysql Workbench. It is a little bit clunky and some options are hard to find, but it works well with ssh tunnelling to remote databases. See this example on how to configure Workbench for remote databases:

if you really want some kind of interface like phpmyadmin, I recommend phpminiadmin which is single file and offer a visual interface. It is less of a hurdle to install than phpmyadmin. It is also easy to remove once you are done.

1 Like

You are right, it was strange that mysql command imported only some tables without an error. I’ve checked the dump and even though it was 270MB in size, it was incomplete. I haven’t work on that project for a while and it seems to have grown a bit.
Sorry for taking up the forum space, though I would like to know more about the vagrant setup process that sets up the dev machine, especially the files like php5-fpm-wordpress.sock and other files with ‘wordpress’ suffix that are replacing the standard nginx and php conf files.

BTW I tried connecting with Mysql Workbench and it repelled me once again with two crashes just while trying to setup an ssh connection to vagrant box, reminding me why I chose to stay with pma in the first place.

1 Like

This is another good one, but it will require you to allow remote connections to the database unless you get one of the paid versions for SSH tunneling.

1 Like


I’ve been having exactly the same trouble that @Ivan_Svaljek was describing. I’d also like to set up phpmyadmin on my local machine, but am not able to do it following the guidelines described in docs.

My issues were exactly the same as @Ivan_Svaljek’s plus “No input file provided” , “Bad Gateway” or just downloading an index.php file living in /usr/share/phpmyadmin. I’ve been trying a bunch of different configurations.

I agree that phpmyadmin is not the best way to go, but I’d like to find out more about php5-fpm-wordpress.sock replacing the standard php-fpm.sock.

Can the Trellis’ current nginx configuration handle sites other than Wordpress? Just would be great to learn a bit more. Thanks!

Can Sequel Pro search within all the tables?

Yes. Yes it can.

20 characters

1 Like