Possible to disable xdebug?

xdebug inserts error markup which breaks plugins like WP Sync DB:

var wpsdb_max_request = '1048576';
var wpsdb_bottleneck = '<br />
  <font size='1'><table class='xdebug-error xe-notice'

Is it possible to disable it? I’m happy to file a bug with plugin developers, but it’s blocking me right now.

Set xdebug_remote_enable: false somewhere like group_vars/all/main.yml

Agreeing with @swalkinshaw, the best place to disable xdebug in group_vars would be to edit the existing xdebug_remote_enable (in group_vars/development/php.yml):

- xdebug_remote_enable: 1
+ xdebug_remote_enable: 0

Then run vagrant provision to apply the change.

1 Like

There’s literally a xdebug_remote_enable field in development/php.yml.

I’m literally the worst. I’m sorry… Thank you for your help.

Slightly better question that will help me in multiple situations: after tweaking things like this, what’s the best way to enable them? vagrant up --provision seems like it might be destructive/overkill, but I’m not sure.

It’s not destructive. Overkill? It re-runs everything so it might take a minute. You can restrict it with ANSIBLE_TAGS=php vagrant provision.

1 Like

Ah okay, I didn’t realize it wasn’t destructive. Thanks.

I have same issue
I have modified php.yml
xdebug_remote_enable: 0
xdebug_remote_connect_back: 0

and run vagrant provision
but I still could see it in browser (development)? What else I need to do?