Problem with bud dev/build with bud sass

Hello everyone, for the past few days, I’ve been having trouble compiling the theme. When running ‘bud dev’ or ‘bud build,’ I encounter the error ‘BudError - extension._make is not a function,’ regardless of the version used, as long as it’s below 6.17.0. Does anyone have any ideas for a solution?

Hi @gol4nsky,

It sounds like some extensions aren’t compatible with the version of Bud you’re running. Make sure all extensions match the exact version of Bud you’re running - delete node_modules and reinstall if unsure. Perfer strict versions over ranges - ie. 6.17.0 over ^6.17.0.


Thanks, there was a problem with ^6.17.0 right here. I changed it to 6.17.0, and now everything is working correctly.

Downgrading bud-sass to 6.17.0 strict fixed the issue for me. When using “^6.17.0” or “^6.18.0” the build fails with the error detailed at the bottom of this post.

I’m having this problem as well with a new project I started tonight. Can you please share which version of Sage you’re using? I’m using 10.7.0 and I’m looking in package.json and my project is using Bud 6.16.1.

I tried updating Bud to 6.17.0 and I still get the same error.

This is a fresh project, the only thing I’ve changed is that I’ve followed the steps to remove Tailwind and add Bootstrap. I also tried using an earlier version of bud-sass (6.17.0) since it was just updated and that didn’t work either.

Every time I run yarn build I get:


✘ extension._make is not a function

error Command failed with exit code 1.