Problem with gulp commands in Version 8 (old version)

i have a older version of sage (i think its a v8) that a developer has developed for me - sadly he is not available anymore.
I have to make some changes in the template but can’t get it to work.
I think that there is a problem with the whole node/gulp/bower setup.
When i try to run “gulp --production” i get the following error:

ReferenceError: primordials is not defined
at fs.js:27:26
at req_ (/node_modules/natives/index.js:143:24)
at Object.req [as require] (
at Object. ***/node_modules/gulp/node_modules/graceful-fs/fs.js:1:37)
at Module._compile (internal/modules/cjs/loader.js:956:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:973:10)
at Module.load (internal/modules/cjs/loader.js:812:32)
at Function.Module._load (internal/modules/cjs/loader.js:724:14)
at Module.require (internal/modules/cjs/loader.js:849:19)
at require (internal/modules/cjs/helpers.js:74:18)

Does anybody know how to get an older version of sage to run with the latest node versions?
Is there any developer scalable i can hire to fix the whole building process?

Try using nvm to switch to an older Node version that’s compatible with Sage 8? You shouldn’t have issues building the theme once you’ve set the version correctly for that project

I tried that already - used 12.12.0 - still got some errors.
Is there a possibility to hire someone for a quick skype session to review the errors?

As Ben said, you want to use an older Node version (not the recent 12.12.0 version) that’s compatible with your version of Sage 8.

For example, on Sage 8.6.0, try Node 6.9 (from the readme).

1 Like

I use nvm and v4.5.0 for older sage 8 based themes with no issues. Good luck!

1 Like

Hi,i used nvm now - my readme says i need Node.js 0.12.x so i used 0.12.18 (found this version here
When i try to do “npm install” i get a lot of errors and it stops with:

npm ERR! Darwin 19.0.0
npm ERR! argv “/.nvm/versions/node/v0.12.18/bin/node" "/.nvm/versions/node/v0.12.18/bin/npm” “install”
npm ERR! node v0.12.18
npm ERR! npm v2.15.11

npm ERR! pngcrush-bin@3.1.1 postinstall: node lib/install.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the pngcrush-bin@3.1.1 postinstall script ‘node lib/install.js’.
npm ERR! This is most likely a problem with the pngcrush-bin package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node lib/install.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs pngcrush-bin
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR!
npm ERR! npm owner ls pngcrush-bin
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /npm-debug.log
*** Template_Git % node v
throw err;
Error: Cannot find module '
at Function.Module._resolveFilename (module.js:336:15)
at Function.Module._load (module.js:278:25)
at Function.Module.runMain (module.js:501:10)
at startup (node.js:129:16)
at node.js:814:3

Sorry to bother you guys - i am a bit scared of not getting this fixed as i am just a designer :slight_smile:

Fixed it - had to do a “npm rebuild node-sass” - thanks for your quick reply!!

This topic was automatically closed after 42 days. New replies are no longer allowed.