Provision failing running existing project

Good morning, I am sharing this for reference, in case someone else is also experiencing this too.
After cloning an existing project on a new macbook laptop, on running Trellis up command, I was experiencing this error:

TASK [ferm : ensure iptables INPUT rules are added] ****************************
fatal: [default]: FAILED! => {"msg": "invalid or malformed argument: ' '"}

Following this thread and applying changes of the pull request
seemed to have initially have solved the issue, but then provision was getting stuck on the

TASK [wordpress-install : Create web root of sites].

Not sure if it’s the best approach, (I am new at Trellis) but removing the , type: ‘nfs’ references from Vagrantfile as mentioned here
solved the issue for me, I hope it helps!



Yeah I get the same on some projects from time to time. Mounting disks on Mac OSX seems a bit inconsistent. However I tried vagrant suspend then vagrant reload --provision a second time and it worked the second time…?

1 Like

Thanks for posting your issue and a resolution!

Just wanted to also say that it’s well worth giving Lima a shot with Trellis as it drops Vagrant, NFS, and Virtualbox/Parallels


No problem, always happy to share! :wink: Thanks for letting me know about Lima, it looks very promising, although, it’s my understanding that it is only available on MacOS Ventura, could you confirm this please?

Yep, that’s the requirement.

1 Like

Well I guess I will update to Ventura soon then, thanks for letting me know!