Provisioning production fails : no "Release file"

It could, but you can update the mirror domain while keeping the version number the same.

picking up on @kim_pp post here, I’m now getting an error on vagrant up … we were currently using this mirror:
http://nyc2.mirrors.digitalocean.com/mariadb/repo/10.2/ubuntu

I changed it to:
http://mirrors.gigenet.com/mariadb/repo/10.5/ubuntu

did vagrant destroy and then vagrant up

Now I’m getting a new error:

TASK [composer : Install configured globally-required packages.] ***************
System info:
  Ansible 2.7.5; Vagrant 2.2.5; Darwin
  Trellis Head
---------------------------------------------------
non-zero return code
Changed current directory to /root/.composer
Do not run Composer as root/super user! See https://getcomposer.org/root for
details
./composer.json has been created
Running composer update hirak/prestissimo
Loading composer repositories with package information
Info from https://repo.packagist.org: #StandWithUkraine
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - hirak/prestissimo[0.1.1, ..., 0.3.1] require ext-curl * -> it is
missing from your system. Install or enable PHP's curl extension.
    - hirak/prestissimo[0.3.2, ..., 0.3.10] require php ^5.3.2 || ^7.0 ->
your php version (8.1.11) does not satisfy that requirement.
    - Root composer.json requires hirak/prestissimo @stable -> satisfiable by
hirak/prestissimo[0.1.1, ..., 0.3.10].

To enable extensions, verify that they are enabled in your .ini files:
    - /etc/php/8.1/cli/php.ini
    - /etc/php/8.1/cli/conf.d/10-opcache.ini
    - /etc/php/8.1/cli/conf.d/10-pdo.ini
    - /etc/php/8.1/cli/conf.d/15-xml.ini
    - /etc/php/8.1/cli/conf.d/20-calendar.ini
    - /etc/php/8.1/cli/conf.d/20-ctype.ini
    - /etc/php/8.1/cli/conf.d/20-dom.ini
    - /etc/php/8.1/cli/conf.d/20-exif.ini
    - /etc/php/8.1/cli/conf.d/20-ffi.ini
    - /etc/php/8.1/cli/conf.d/20-fileinfo.ini
    - /etc/php/8.1/cli/conf.d/20-ftp.ini
    - /etc/php/8.1/cli/conf.d/20-gettext.ini
    - /etc/php/8.1/cli/conf.d/20-iconv.ini
    - /etc/php/8.1/cli/conf.d/20-igbinary.ini
    - /etc/php/8.1/cli/conf.d/20-msgpack.ini
    - /etc/php/8.1/cli/conf.d/20-phar.ini
    - /etc/php/8.1/cli/conf.d/20-posix.ini
    - /etc/php/8.1/cli/conf.d/20-readline.ini
    - /etc/php/8.1/cli/conf.d/20-shmop.ini
    - /etc/php/8.1/cli/conf.d/20-simplexml.ini
    - /etc/php/8.1/cli/conf.d/20-sockets.ini
    - /etc/php/8.1/cli/conf.d/20-sysvmsg.ini
    - /etc/php/8.1/cli/conf.d/20-sysvsem.ini
    - /etc/php/8.1/cli/conf.d/20-sysvshm.ini
    - /etc/php/8.1/cli/conf.d/20-tokenizer.ini
    - /etc/php/8.1/cli/conf.d/20-xdebug.ini
    - /etc/php/8.1/cli/conf.d/20-xmlreader.ini
    - /etc/php/8.1/cli/conf.d/20-xmlwriter.ini
    - /etc/php/8.1/cli/conf.d/20-xsl.ini
    - /etc/php/8.1/cli/conf.d/25-memcached.ini
You can also run `php --ini` in a terminal to see which files are used by PHP
in CLI mode.
Alternatively, you can run Composer with `--ignore-platform-req=ext-curl` to
temporarily ignore these required extensions.

Installation failed, deleting ./composer.json.
failed: [default] (item={u'name': u'hirak/prestissimo'}) => {"changed": true, "cmd": ["/usr/local/bin/composer", "global", "require", "hirak/prestissimo:@stable", "--no-progress"], "delta": "0:00:00.554042", "end": "2022-10-14 05:35:29.305421", "item": {"name": "hirak/prestissimo"}, "rc": 2, "start": "2022-10-14 05:35:28.751379", "stderr_lines": ["Changed current directory to /root/.composer", "Do not run Composer as root/super user! See https://getcomposer.org/root for details", "./composer.json has been created", "Running composer update hirak/prestissimo", "Loading composer repositories with package information", "Info from https://repo.packagist.org: #StandWithUkraine", "Updating dependencies", "Your requirements could not be resolved to an installable set of packages.", "", "  Problem 1", "    - hirak/prestissimo[0.1.1, ..., 0.3.1] require ext-curl * -> it is missing from your system. Install or enable PHP's curl extension.", "    - hirak/prestissimo[0.3.2, ..., 0.3.10] require php ^5.3.2 || ^7.0 -> your php version (8.1.11) does not satisfy that requirement.", "    - Root composer.json requires hirak/prestissimo @stable -> satisfiable by hirak/prestissimo[0.1.1, ..., 0.3.10].", "", "To enable extensions, verify that they are enabled in your .ini files:", "    - /etc/php/8.1/cli/php.ini", "    - /etc/php/8.1/cli/conf.d/10-opcache.ini", "    - /etc/php/8.1/cli/conf.d/10-pdo.ini", "    - /etc/php/8.1/cli/conf.d/15-xml.ini", "    - /etc/php/8.1/cli/conf.d/20-calendar.ini", "    - /etc/php/8.1/cli/conf.d/20-ctype.ini", "    - /etc/php/8.1/cli/conf.d/20-dom.ini", "    - /etc/php/8.1/cli/conf.d/20-exif.ini", "    - /etc/php/8.1/cli/conf.d/20-ffi.ini", "    - /etc/php/8.1/cli/conf.d/20-fileinfo.ini", "    - /etc/php/8.1/cli/conf.d/20-ftp.ini", "    - /etc/php/8.1/cli/conf.d/20-gettext.ini", "    - /etc/php/8.1/cli/conf.d/20-iconv.ini", "    - /etc/php/8.1/cli/conf.d/20-igbinary.ini", "    - /etc/php/8.1/cli/conf.d/20-msgpack.ini", "    - /etc/php/8.1/cli/conf.d/20-phar.ini", "    - /etc/php/8.1/cli/conf.d/20-posix.ini", "    - /etc/php/8.1/cli/conf.d/20-readline.ini", "    - /etc/php/8.1/cli/conf.d/20-shmop.ini", "    - /etc/php/8.1/cli/conf.d/20-simplexml.ini", "    - /etc/php/8.1/cli/conf.d/20-sockets.ini", "    - /etc/php/8.1/cli/conf.d/20-sysvmsg.ini", "    - /etc/php/8.1/cli/conf.d/20-sysvsem.ini", "    - /etc/php/8.1/cli/conf.d/20-sysvshm.ini", "    - /etc/php/8.1/cli/conf.d/20-tokenizer.ini", "    - /etc/php/8.1/cli/conf.d/20-xdebug.ini", "    - /etc/php/8.1/cli/conf.d/20-xmlreader.ini", "    - /etc/php/8.1/cli/conf.d/20-xmlwriter.ini", "    - /etc/php/8.1/cli/conf.d/20-xsl.ini", "    - /etc/php/8.1/cli/conf.d/25-memcached.ini", "You can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.", "Alternatively, you can run Composer with `--ignore-platform-req=ext-curl` to temporarily ignore these required extensions.", "", "Installation failed, deleting ./composer.json."], "stdout": "", "stdout_lines": []}

I looked for a mirror with mariadb 10.2 for ubuntu 18.04, but there is none … lowest version is 10.3, there is no older one.

any advice?

That error says you’re missing PHP’s curl extension… It doesn’t seem related to MariaDB?

require ext-curl * -> it is
missing from your system. Install or enable PHP's curl extension.

I’d suggest opening a new topic if you’re having trouble with that specifically.

FWIW, prestissimo has not been necessary since Composer v2 was released. I would get rid of that from your project.

1 Like