Public Path not changing

Version : Sage (10.4.1)
I am not sure if I have misunderstood, but I cannot change the public path.

I have installed a new font. Bud build compiles the font but in the css file the public folder the URL is /themes/sage/fonts/
I have changed the theme folder name and I thought changing .setPublicPath(‘/app/themes/theme-name/public/’) would change the assets url, but it does not seem to work and I end up with a 404 on the font.

What am I missing?

Is it a Bedrock Wordpress install?

:face_in_clouds: just drifting by with a reminder to bud dev --force to wipe the bud cache prior to 6.12.0… :crossed_fingers:


No it’s, Sage 10 6.7.3

This ran into an error.

        throw ex;

TypeError: The 'compilation' argument must be an instance of Compilation

--force does work.

Try yarn dev --force or npm run dev --force - whatever you’re using.

Yeah I realised my error. See the above edit I made to my post on the error it threw. Thanks

My guess would be that you should look into updating your publicpath:

It’s changed but I don’t know what cause d it. Annoyingly it changed to the wrong URL and I cannot reforce it to change again.

/// FIXED IT ///

I manually deleted the budfiles hidden cache folder and rebuilt it with the correct URL.
Works now.