Radicle - lando server doesnt start

I’ve followed the installation guide, but my lando server won’t start.

Radicle 1.2.0
Lando v3.18.0
Docker 4.16.0

All the docker container seem to start as normal, but it can’t open a proxy to http://radicle.lndo.site/


    ✔ https://localhost:51340 [302]
    ✔ http://localhost:51341 [302]

:thinking: What operating system are you using?

I‘m using a Mac, so its Mac OS

Are you using any other Docker-based local dev environments?

What do you typically use for local dev?

Nothing Docker based, i‘m using Mamp for local databases and PHP Environments…

Have you tried shutting down MAMP entirely? It seems like there’s a DNS conflict somewhere on your system

If you’re open to non-Lando alternatives, both Trellis w/ Lima and Laravel Valet/Herd are also really great options. There’s also folks that are using DDEV with Radicle, but that’s Docker based as well and you might run into the same issue that you’re experiencing with Lando.

Yup, i‘ve tried that, but it didn‘t make and difference. Where exactly could such a DNS conflict came from?

I haven‘t tried trellis because the project will ne using a shared Webhosting, so i Cent benefit from all the Stufe that trellis is offering…

I would assume from another local dev tool but I can’t be entirely certain. It seems like you’re hitting this issue but there’s not any real solutions :confused:

You can use Trellis just for your local development (or even just for deployments) — it doesn’t need to be all-or-nothing with Trellis and folks are using it in all sorts of different ways depending on their needs

That said, I’d probably try out Laravel Herd next if I were you. It supports Radicle out of the box.

I’ve tried to remove Mamp completely and upgraded Docker Desktop to the newest Version but it had no effect - i’m still getting the error.

I’ve got trellis up and running, so this works now. Thank you for the support!

1 Like

You’re welcome, glad you’ve got something up and running!

I was having this issue today. For me, the problem was the network I was connecting to was preventing the URL proxy from working - connecting to a different network fixed the issue. Leaving the relevant Lando documentation here in case anyone else stumbles onto this thread looking for an answer:

1 Like