@roots/bud-sass Installed version (^6.14.1) does not match bud.js version (6.7.3)

So I created a fresh install of Sage 10 WordPress theme and have started building a website with it a few days ago. I then decided I want to add Sass support to the project, so I found this guide here: Using Sass | Sage Docs | Roots

After installing the @roots/bud-sass with yarn, whenever I run yarn build or yarn dev now, I’m encountering an issue that mentions:

@roots/bud-sass Installed version (^6.14.1) does not match bud.js version (6.7.3)

I’m running Node v18.16.1 on macOS Monterey 12.5, and this is currently my package.json file:

  "name": "sage",
  "private": true,
  "browserslist": [
    "extends @roots/browserslist-config"
  "engines": {
    "node": ">=16.0.0"
  "type": "module",
  "scripts": {
    "dev": "bud dev",
    "build": "bud build",
    "translate": "yarn translate:pot && yarn translate:update",
    "translate:pot": "wp i18n make-pot . ./resources/lang/sage.pot --include=\"app,resources\"",
    "translate:update": "for filename in ./resources/lang/*.po; do msgmerge -U $filename ./resources/lang/sage.pot; done; rm -f ./resources/lang/*.po~",
    "translate:compile": "yarn translate:mo && yarn translate:js",
    "translate:js": "wp i18n make-json ./resources/lang --pretty-print",
    "translate:mo": "wp i18n make-mo ./resources/lang ./resources/lang"
  "devDependencies": {
    "@roots/bud": "6.7.3",
    "@roots/bud-sass": "^6.14.1",
    "@roots/bud-tailwindcss": "6.7.3",
    "@roots/sage": "6.7.3"
  "dependencies": {
    "@mdi/font": "^7.2.96",
    "swiper": "^10.0.3"

based on this, does this mean I’ll need to downgrade my version of bud signfiicantly to resolve the issue? surely i’m not the only one who has encountered this issue recently

All @roots/bud packages should have the same or as close as possible versions.
In your package.json most @roots/bud packages are of version 6.7.3, but the version range for @roots/bud-sass is higher (^6.14.1).

The safest and easiest fix is setting the version of @roots/bud-sass to 6.7.3
(and refresh the packages using yarn or npm);

"@roots/bud-sass": "^6.14.1"
"@roots/bud-sass": "6.7.3"

yarn CLI command for installing @roots/bud-sass of specific version:
yarn add @roots/bud-sass@6.7.3 --dev

:thinking: Does yarn/npm allow to nudge/force specific packages to have the same or close version? This would prevent this issue in the future, as just installing @roots/bud-sass can easily result in a newer package version being required than the ones of the existing @roots/bud packages.

changing @roots/bud-sass to 6.7.3 fixed this issue, I just assumed that 6.14.1 was the latest version as per I found on the npm package here: https://www.npmjs.com/package/@roots/bud-sass?activeTab=readme

thanks for your assistance! :slight_smile: