Roots/Sass build fails

I did a fresh Roots Bootstrap install and followed the steps to remove the Tailwind files. Upon running yarn build, it compiles with a few errors. Mainly what’s displayed in the screenshot. Has anyone else experienced this before?

Did you remove @roots/bud-tailwindcss from package.json? If not, you should do that and re-run the install. If you already have you might want to rm -rf node_modules to make sure that ./node_modules/@roots/bud-tailwindcss is not resolvable by @roots/sage.

If @roots/sage finds @roots/bud-tailwindcss it’ll try to use it. Tailwind is dying because it can’t find the config file.


Thanks for your detailed reply. Yes I can confirm that @roots/bud-tailwindcss is removed from package.json.

After running the rm -rf node_modules and re-running my install and build I still get the same error. I’m truly puzzled.

Have you also adjusted the bud.conf.mjs and removed the tailwind-specific references there?

1 Like

Yes, I did try that.

Updating this thread to let folks know I have resolved the issue. A postcss file in my root directory was causing an issue. Thanks for your input.