Roots SASS, cannot load compass

Hi there, I have Installed the Wordpress Starter Theme (SASS). When I use the command “grunt dev” and I change something in the app.scss file the task will start running and will give me an error “Cannot load compass”.

Does anyone know what this is causing (and yes compass gem is installed)?

I’ve just gotten back to trying to use roots on a new site and am having the same issue. I can run compass itself just fine but using grunt over it gives the same error.


Hey guys,

I’ll take a look at this soon.

I fixed the problem. I uninstalled sass and compass. Then instead of installing sass first I just installed compass. This will install the right version of sass too. After that it worked like a charm.

1 Like

Good to know, thanks Marcelaerts.

This is one reason I’m actually starting to prefer LESS over SASS lately… not having to deal with Ruby gems. Seems like every time I start a new project and use SASS, I have issues getting it set up correctly.

This also worked for me. Thanks.