Running Acorn CMDs Inside Docker Container

Straight off the bat I’ll admit I’m a total n00b when it comes to docker however at the point I’m a bit lost and I need some help.

I’ve create a docker compose file that spins up WP the DB and the WPCLI. I run my cli commands as such: - docker-compose run --rm wpcli plugin list to list the currently installed plugins.

However one issue I’m having is when I run docker-compose run --rm wpcli acorn help I get : -

/usr/local/bin/docker-entrypoint.sh: exec: line 11: acorn: not found
ERROR: 127

I’ve installed Acorn as a plugin but I don’t have a clue how this relates to docker and I’m feeling a bit lost.

Anyone help?

Even if Acorn is activated as a plugin it still needs to be booted

Example from the Sage theme

Thanks for the reply Ben!

Hmmm I’m not sure … I’ve installed acorn via composer and a plugin… just to see if it works and then dumping var_dump(\Roots\bootloader()) all I get is NULL returned.

I also tested this on a mamp stack and going either the plugin/composer route it works fine it’s just something in docker causing things to totally bork :frowning:

Is there a git repo you could push up for us to try out and reproduce?