Roots Discourse

Sage 10 Appeareance > Widgets does not work

Hey all. If I try to access Appeareance > Widgets I get the following error:

ErrorException thrown with message "wp_enqueue_script() was called <strong>incorrectly</strong>. "wp-editor" script should not be enqueued together with the new widgets editor (wp-edit-widgets or wp-customize-widgets). Please see <a href="https://wordpress.org/support/article/debugging-in-wordpress/">Debugging in WordPress</a> for more information. (This message was added in version 5.8.0.)"

Stacktrace:
#8 ErrorException in /srv/www/retrogames.cool/current/web/wp/wp-includes/functions.php:5663
#7 trigger_error in /srv/www/retrogames.cool/current/web/wp/wp-includes/functions.php:5663
#6 _doing_it_wrong in /srv/www/retrogames.cool/current/web/wp/wp-includes/widgets.php:2039
#5 wp_check_widget_editor_deps in /srv/www/retrogames.cool/current/web/wp/wp-includes/class-wp-hook.php:303
#4 WP_Hook:apply_filters in /srv/www/retrogames.cool/current/web/wp/wp-includes/class-wp-hook.php:327
#3 WP_Hook:do_action in /srv/www/retrogames.cool/current/web/wp/wp-includes/plugin.php:470
#2 do_action in /srv/www/retrogames.cool/current/web/wp/wp-admin/admin-header.php:147
#1 require_once in /srv/www/retrogames.cool/current/web/wp/wp-admin/widgets-form-blocks.php:69
#0 require in /srv/www/retrogames.cool/current/web/wp/wp-admin/widgets.php:31

I’ve looked up solutions to this, but nothing seems to work that doesn’t outright disable the Gutenberg editor for it. For example I tried these two:

  • This one didn’t have a effect

*This one produces a new error:

Illuminate\Contracts\Filesystem\FileNotFoundException thrown with message "Asset [/srv/www/retrogames.cool/current/web/app/themes/rgame/public/scripts/manifest.asset.php] not found."

Stacktrace:
#6 Illuminate\Contracts\Filesystem\FileNotFoundException in /srv/www/retrogames.cool/current/web/app/themes/rgame/vendor/roots/acorn/src/Roots/Acorn/Assets/Asset/PhpAsset.php:17
#5 Roots\Acorn\Assets\Asset\PhpAsset:load in /srv/www/retrogames.cool/current/web/app/themes/rgame/app/setup.php:27
#4 App\{closure} in /srv/www/retrogames.cool/current/web/wp/wp-includes/class-wp-hook.php:303
#3 WP_Hook:apply_filters in /srv/www/retrogames.cool/current/web/wp/wp-includes/class-wp-hook.php:327
#2 WP_Hook:do_action in /srv/www/retrogames.cool/current/web/wp/wp-includes/plugin.php:470
#1 do_action in /srv/www/retrogames.cool/current/web/wp/wp-admin/widgets-form-blocks.php:64
#0 require in /srv/www/retrogames.cool/current/web/wp/wp-admin/widgets.php:31

so, i’m wondering if anyone has a solution. Thank you!