Sage 10 doesn't start to compile cache on wp-engine until

Hello, I noticed Sage 10 doesn’t start to compile cache when I deploy the website on wp-engine until I go on “Apparenace > Customize” on WordPress. At this point, it starts to produce cache, and the website shows up.

Anyone incurred in this kind of issue?

Thank you

Sage doesn’t compile Blades until they are requested, i.e. someone visits the page that requires them. If you have a need for Blades to be compiled earlier, you can run wp acorn view:cache in your production environment.

1 Like

Yes the problem is if I deploy the website and then I visit the homepage (e.g) it’s doesn’t compile anything until I go (as I said) in "Apparenace > Customize”.

Run wp acorn optimize before deployment and make sure to include the storage folder.

before? every time I do a new deployment I delete the theme folder.

Guys, I tried to run both commands but nothing has fixed the problem.
After I push all the content on wp-engine I run the wp acorn view:cache and cache will be generated but the front-end is still blank (the app container in HTML is empty). I tried also to run acorn optimize but nothing change. The only thing to make that work is to go to the “customize” page in WordPress. After that, the website is rendered correctly.

Any hint?

Solved from the wp-engine supports, was an issue on the server-side.

Fixed it. You don’t need to contact WPE support. I should have known because it’s the same way you fix Sage 9 on WPEngine.

In your wp-content/themes/theme-name/config/view.php


// 'compiled' => get_theme_file_path('/storage/framework/views'),
'compiled' => '/tmp/sage-cache',

This topic was automatically closed after 42 days. New replies are no longer allowed.