Sage 10 – Problem with WS-Form 401 error


Kinsta is deactivating PHP 7.4 in January 2023. Now, i’m trying to move my Sage 9 theme to Sage 10. Generally everything works fine but i got a problem with WS-Form plugin. When i’m logged out (Wordpress) all forms are not shown and i always get an 401 error. I’ve never disabled wp rest api. I also removed security plugins, WP-Rocket and tried to activate the endpoint via plugin but nothing helped.

JS-Console: …/wp-json/ws-form/v1/form/4/full 401

If i change to another theme, all forms are visible. With Sage 9 and almost the same setting (plugins, content) everything works fine.

I will appreciate any help. Thank you very much.

I had to remove wp_footer() in layout template to get the form working (without 401 error). Does anyone have an idea what exactly is causing the problem?

wp_head and wp_footer are no longer in the Blade views in Sage 10.

I believe it was for plugin compatibility, the html, head, and body elements all exist in the index.php file and should not be in any of the layouts.

1 Like

@EHLOVader Thx, that was the problem :slight_smile: