Sage 10 Proxy Localhost:3000 Not Working

Hello, I am running a new installation of Trellis on Ubuntu 20.10 and and am using Trellis-CLI. I have the instance up and running and have installed the dev-main version of Sage 10 in /site/web/app/themes/testtheme. The issue is the proxy of my domain set in bud.config.js to localhost:3000 isn’t working.

.proxy(‘http://cleantheme.test’); results in the following after running yarn dev:

⠧ [dev] http://localhost:3000
⠧ [proxy] http://cleantheme.test
◉ 500 [dev] http://localhost:3000
◉ 400 [proxy] http://cleantheme.test
◉ 500 [dev] http://localhost:3000
◉ 400 [proxy] http://cleantheme.test
◉ 500 [dev] http://localhost:3000
◉ 400 [proxy] http://cleantheme.test

Visiting localhost:3000 results in: Error occurred while trying to proxy: localhost:3000/

I appreciate any assistance you can provide me. Please let me know if you need more information.

Regards,

Dorian

Have you configured .proxy('[...]') in your bud.config.js?

Yes, as noted in my original post. .proxy(‘http://cleantheme.test’); I don’t have any issues running my react apps on localhost:3000 so I know that port isn’t being blocked. I also confirmed the port isn’t already in use.

D

what about http://cleantheme.test:3000?

Also, it seems you are getting a 400 response on http://cleantheme.test. Are you sending out a 400 header?

http://cleantheme.test loads fine, adding :3000 to the url doesn’t help. I’m not sending a 400 header, I’m just running yarn dev. I just tried testing an understrap theme on port 3000 and it’s also failing which leads me to believe the issue is further down the roots stack. Any other suggestions?

Thanks,

D

WSL 2? Vagrant VM? Development server reachable by terminal/bud?

Ubuntu 20.10 workstation, Virtual box Vagrant VM is running, I can Vagrant ssh into the VM.

Can you wget/curl, from inside the terminal you run bud, the development site/URL that you are also proxying in bud?

Aah, running wget to cleantheme.test tipped me off to conflicting IP addresses assigned in /etc/hosts. I cleaned them up to match my vagrant IP and I’m good to go. Problem resolved. Thanks!!

D

Ma Kore?
I’m stuck on this process too and trying to do the config with Local By wheel:/

My host file as follow:

::1 wordpress.local
127.0.0.1 wordpress.local
::1 www.wordpress.local
127.0.0.1 www.wordpress.local

changed to :

Local by Flywheel - Start

#::1 wordpress.local #Local Site
127.0.0.1 wordpress.local #Local Site
#::1 www.wordpress.local #Local Site
#127.0.0.1 www.wordpress.local #Local Site

still no success

bud.config.js
/**
* Target URL to be proxied by the dev server.
*
* This should be the URL you use to visit your local development server.
*/
.proxy(‘http://wordpress.local’)

/**
 * Development URL to be used in the browser.
 */
.serve('http://localhost:3000');