Roots Discourse

Sage 10 proxyUrl?

I have one project I started a couple months ago with Sage 10 and Tailwind JIT. When I launch this project, it proxies to localhost:3002 and Tailwind JIT runs very fast upon making any changes.

I’ve started a different project on the same setup, except this new project proxies to localhost:3000 and is incredibly slow!

I have used fkill to kill port 3000 and try again but it remains extremely slow. I’m not sure if changing the port on the new project will help but I can’t even figure out where to change it. Does anyone know how I can do this?

You should be able to add a “port” argument in your webpack.mix.js file in your Sage 10 root directory.

It should be as simple as:

mix
    .setPublicPath('./public') //This is already in the default config
    .browserSync({
        proxy: 'https://your-local-domain.dev', 
        port: '3072' // Add any random port number here, if that's what you want
    })
    .options({ //And so forth with more mix options

@evankford
That does work great, thank you.
I am still experiences very slow load times however on this new project.