Roots Discourse

Sage 10 - Yarn keeps crashing

Hi there!

My dev site has been running smoothly up (for weeks) until today. My yarn keeps crashing after I run yarn start while doing simple things like updating html & css.

I don’t get any helpful error messages in console except this:

[Browsersync] Watching files…
error Command failed with exit code 1.
info Visit yarn run | Yarn for documentation about this command.

So my guess is that something happens while browsersync tries to reload the page. I don’t know what the issue though and it’s really annoying to have to restart yarn each time I want to see the site.

What did you change recently? Have you tried using git bisect to determine where the problem was introduced?

I didn’t change anything per se. Just added new blade views, css, etc…
I’m basically building the homepage as I go, with new composers, etc…

I run the site with yarn start and it compiles well but after a few minutes looking at my page, it just stops and then I need to restart it.

If it was working and now it’s not, something changed. You added something that broke it, or your environment changed and that broke it. If you can identify a commit in your history that works then you have a starting point for looking for where the problem was introduced—git bisect is very helpful for this. If you can find a good commit in your history, then something in your environment may have changed—ie you changed your node version, updated your browser or another system-level soft dependency, etc.

That’s the thing, nothing has changed at all in the environment other than adding new composers, blade templates, css files and javascript functions. If there was an issue with those, I’d have an error message on the frontend.

The only thing I can say is that we’re two developers working on the same git and my other dev does install new modules via npm. Would that have been the issue?

Have you tried looking for a good commit and using git bisect?

It seems like it was a cache problem. I couldn’t find a good or bad Git since nothing changed in the core of sage. Thanks

This topic was automatically closed after 42 days. New replies are no longer allowed.