Sage 8.0.0 & WordPress Theme Issue


I just grabbed Sage 8.0.0 and wanted to deploy my production version.

I ran the “gulp --production” command and uploaded my theme to the WordPress themes folder and when I activate the theme in the WP admin I just get a blank white page.

What step am I missing or is this related to a bug? Chances are it’s a step I’m missing.

Any help would be greatly appreciated.


1 Like

I just tried installing Sage though the WordPress theme uploaded by uploading the file. Same thing happens, when I activate it my site goes to a dead white page.

When I would upload the theme file though WordPress I would at least get a working back-end and front-end, it just was not styled until I ran grunt on it.

what happens if you turn on PHP error reporting?

Sage requires PHP 5.4+ now so that’s the first thing you should check.

Thank you for the help. It looks like PHP version may be the issue I’m having. Server is currently running PHP 5.3.3.

Thanks for the insight!

If you are looking for quick patch It’s probably something in breaking 5.3.

But you will run into lots of other problems if you aren’t on 5.4, so recommend upgrading to 5.4 anyway.

I may have a similar problem. I had developed my website local via MAMP and it was everything fine. But when I uploaded my theme to the server I got a blank page when I try to activate the theme. The PHP of the server is 5.2.6. I couldnt update the PHP at the server yet, but it seens being the same problem, right?

If your PHP isn’t 5.4+ then that’s definitely the problem.